Ubuntu 18.04

Installation

Download the .deb package and install it by the following command:

apt-get install -y <packagename>.deb

This command should also install recommended packages (stockfish, alsa-utils, espeak).

<packagename>.deb is the name of nocheto or nochetoengi package, i.e. nochetoengi_0.33-0_amd64.deb or nocheto_0.33-0_amd64.deb.

Continue with postinstall instructions.

ldd output

Nocheto for this distribution require: libgraphicsmagick++-q16-12 libgcc1 libedit2 libssl1.1 libsoci-sqlite3-3.2v5 libsqlite3-0

ldd /usr/local/bin/nocheto
        linux-vdso.so.1 (0x00007fffd1bf9000)
        libGraphicsMagick++-Q16.so.12 => /usr/lib/libGraphicsMagick++-Q16.so.12 (0x00007f02aa063000)
        libedit.so.2 => /usr/lib/x86_64-linux-gnu/libedit.so.2 (0x00007f02a9e2c000)
        libcrypto.so.1.1 => /usr/lib/x86_64-linux-gnu/libcrypto.so.1.1 (0x00007f02a9961000)
        libssl.so.1.1 => /usr/lib/x86_64-linux-gnu/libssl.so.1.1 (0x00007f02a96d4000)
        libsoci_sqlite3.so.3.2 => /usr/lib/x86_64-linux-gnu/libsoci_sqlite3.so.3.2 (0x00007f02a94be000)
        libsoci_core.so.3.2 => /usr/lib/x86_64-linux-gnu/libsoci_core.so.3.2 (0x00007f02a9281000)
        libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f02a9062000)
        libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f02a8cd9000)
        libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f02a893b000)
        libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f02a8723000)
        libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f02a8332000)
        libGraphicsMagick-Q16.so.3 => /usr/lib/libGraphicsMagick-Q16.so.3 (0x00007f02a7ddb000)
        libtinfo.so.5 => /lib/x86_64-linux-gnu/libtinfo.so.5 (0x00007f02a7bb1000)
        libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f02a79ad000)
        libsqlite3.so.0 => /usr/lib/x86_64-linux-gnu/libsqlite3.so.0 (0x00007f02a76a4000)
        /lib64/ld-linux-x86-64.so.2 (0x00007f02aa833000)
        libjbig.so.0 => /usr/lib/x86_64-linux-gnu/libjbig.so.0 (0x00007f02a7496000)
        libwebp.so.6 => /usr/lib/x86_64-linux-gnu/libwebp.so.6 (0x00007f02a722d000)
        libwebpmux.so.3 => /usr/lib/x86_64-linux-gnu/libwebpmux.so.3 (0x00007f02a7023000)
        liblcms2.so.2 => /usr/lib/x86_64-linux-gnu/liblcms2.so.2 (0x00007f02a6dcb000)
        libtiff.so.5 => /usr/lib/x86_64-linux-gnu/libtiff.so.5 (0x00007f02a6b54000)
        libfreetype.so.6 => /usr/lib/x86_64-linux-gnu/libfreetype.so.6 (0x00007f02a68a0000)
        libjpeg.so.8 => /usr/lib/x86_64-linux-gnu/libjpeg.so.8 (0x00007f02a6638000)
        libpng16.so.16 => /usr/lib/x86_64-linux-gnu/libpng16.so.16 (0x00007f02a6406000)
        libwmflite-0.2.so.7 => /usr/lib/x86_64-linux-gnu/libwmflite-0.2.so.7 (0x00007f02a61e8000)
        libXext.so.6 => /usr/lib/x86_64-linux-gnu/libXext.so.6 (0x00007f02a5fd6000)
        libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007f02a5c9e000)
        libbz2.so.1.0 => /lib/x86_64-linux-gnu/libbz2.so.1.0 (0x00007f02a5a8e000)
        libxml2.so.2 => /usr/lib/x86_64-linux-gnu/libxml2.so.2 (0x00007f02a56cd000)
        libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f02a54b0000)
        libgomp.so.1 => /usr/lib/x86_64-linux-gnu/libgomp.so.1 (0x00007f02a5281000)
        liblzma.so.5 => /lib/x86_64-linux-gnu/liblzma.so.5 (0x00007f02a505b000)
        libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007f02a4e33000)
        libicuuc.so.60 => /usr/lib/x86_64-linux-gnu/libicuuc.so.60 (0x00007f02a4a7b000)
        libXau.so.6 => /usr/lib/x86_64-linux-gnu/libXau.so.6 (0x00007f02a4877000)
        libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007f02a4671000)
        libicudata.so.60 => /usr/lib/x86_64-linux-gnu/libicudata.so.60 (0x00007f02a2ac8000)
        libbsd.so.0 => /lib/x86_64-linux-gnu/libbsd.so.0 (0x00007f02a28b3000)
        librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f02a26ab000)